Disruption in Meta Channels

Incident Report for CommBox

Resolved

All Meta Services have been restored.
Posted Jun 12, 2026 - 21:38 IDT

Identified

We have identified that the disruption affecting WhatsApp, Facebook, and Instagram channels is caused by an ongoing global outage on Meta's infrastructure. Our team is monitoring the situation closely and will update this page as soon as Meta resolves the issue.
Posted Jun 12, 2026 - 19:07 IDT
This incident affected: Third Party Connectors (Facebook, WhatsApp, Instagram).